British Only Forums
British Only Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 British Motorcycle Forums
 Norton Motorcycles
 Commando oil plug & screen
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

GJM_T120

USA
11 Posts

Posted - 02/28/2006 :  23:38:25  Show Profile  Reply with Quote

Is there a trick to removing the big (1 1/2") plug at the bottom of the case that holds the oil filter screen. The bike is a 1971 Commando. I've pulled so much torque that I'm afraid something is going to shear.

Is this plug reverse threaded??
thx

captain chaos

USA
9 Posts

Posted - 03/08/2006 :  16:05:52  Show Profile  Reply with Quote
I have a 71 commando, and haven't experienced the problem you describe. The plug turns out counter-clockwise, as you'd expect.

It seems odd that a part that's in constant contact with hot oil could get stuck like that. Mine doesn't want to stay in. The giant wrench one has to use should loosen anything.

Any chance it was put in cross-threaded (GASP)?
Go to Top of Page

GJM_T120

USA
11 Posts

Posted - 03/12/2006 :  20:55:10  Show Profile  Reply with Quote
quote:
Originally posted by captain chaos

I have a 71 commando, and haven't experienced the problem you describe. The plug turns out counter-clockwise, as you'd expect.

It seems odd that a part that's in constant contact with hot oil could get stuck like that. Mine doesn't want to stay in. The giant wrench one has to use should loosen anything.

Any chance it was put in cross-threaded (GASP)?

Go to Top of Page

GJM_T120

USA
11 Posts

Posted - 03/12/2006 :  20:56:34  Show Profile  Reply with Quote
quote:
Originally posted by captain chaos

I have a 71 commando, and haven't experienced the problem you describe. The plug turns out counter-clockwise, as you'd expect.

It seems odd that a part that's in constant contact with hot oil could get stuck like that. Mine doesn't want to stay in. The giant wrench one has to use should loosen anything.

Any chance it was put in cross-threaded (GASP)?



I don't think so. I've talked to the previous owner and he didn't recall any problem. I guess I'll just have to keep trying

thanks
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
British Only Forums © British Only Motorcycles & Parts Inc. Go To Top Of Page
This page was generated in 0.06 seconds. Snitz Forums 2000